HomeSite mapMail usSearch in site
EDS-Soft
ElectroDynamic Systems Software ScientificTM
Antenna Systems ResearchTM



Antenna Array


Antenna array

Complex directional antenna consists of separate near-omnidirectional antennas (radiating elements) positioned in the space and driven by high-frequency …

(from 'Glossary' of our web–site)






RefereesHelp Race™ Documentation



RefereesHelp Race is a professional solution for keeping record at running, swimming and skiing competitions. RefereesHelp Race can help register the contestants and also makes it easy to get the tournament scores, fill and print the score-sheets.



Main window

The main window is divided into several areas:

“Main menu” — see details in “Main menu” section.
“Toolbars” — see details in “Toolbars” section.
“Side panel” — displays the statistics on the number of contestants from every settlement and on every race.
“Statusbar” — displays the information on current time and date, currently opened table and program status.
“Tables area” — displays the tables with data.


“Main” menu

The program's main menu contains the following items: “File”, “View”, “Races”, “Contestants”, “Statistics”, “Settings”, “Help”


“File” menu

“Print settings” — opening the print setup dialog window.
“Preview” — preview of the document before printing.
“Print reports” — printing current score-sheet, all start or finish lists.
“Exit” — exiting the program.


“View” menu

“Designer” — opening the list designer.
“Language” — choosing program’s interface language.
“Style” — choosing and changing the appearance style.
“Toolbars” — hide and unhide the toolbars.
“Sidebar” — hide and unhide the sidebar statistics.
“Status bar” — hide and unhide the status bar.


“Races” menu

This menu is designed to open the dialog windows, where you can enter the details of new contestants, edit the contestants’ details, enter the results, edit the existing data, browse the start and finish lists and lists of winners or view the entire database on each race.

Each menu item indicates the length of each race in the database and contains the following sub-menus:

“New contestants” — displays the dialog window to add a new contestant.
“Results” — displays the dialog window to enter the contestant’s results.
“Edit” — displays the dialog window to edit the contestant’s details.
“Show” — displays the details of the contestants of both sexes, enrolled on the start, finish or winner lists.
“Browse database” — browses the contestants' details.


“Contestants” menu

“Age groups” — opens the dialog window which contains the contestants’ details according to their age groups and races.
“Search contestants” — opens the dialog window to search the contestants’ details.
“Youngest and oldest” — displays the details of the youngest and the oldest contestants on each race.


“Statistics” menu

“Best results” — opens the dialog window to search the record results on each race.


“Settings” menu

“Current year” — Choosing the year of competition.
“Move table” — opens the dialog window to import data from database external files.
“External editor” — opens the database editor.
“Refresh view” — imports data from database text files.
“Program Configuration” — opens the dialog window of program configuration settings.


“Help” menu

“Help” — opens program help.
“What’s new?” — opens the dialog window, containing the information on new features of the current program version and change log of the previous version.
“Internet links” — throws to the program developers’ site, program’s web page or to the program registration (buying) page.
“About” — opens the dialog window “About the program”.


Toolbars

In the program’s main window there are three toolbars located below the main menu. The toolbars contain buttons that activate the frequently used functions. The function of each button corresponds to a certain menu item. Using toolbars saves time, because to activate any function you only need to click the button on toolbar.

The “Races” toolbar contains the list of races to switch between and the buttons for working with the chosen race: “Browse database”, “Edit”, “Add new contestant», “Enter” и “Delete database”. This toolbar is similar to the “Races” one of the Main menu.

The Base toolbar contains “Age groups”, “Search contestants”, “Program Configuration”, “External editor” and “Refresh view” buttons, which are similar to the certain items of the Main menu.

The “Help” toolbar contains “Help”, “What’s new” and “About” buttons. This toolbar is similar to the “Help” menu of the Main menu.



Configuration

The program and database configuration is set in the “Program configuration” dialog window, which can be opened by:

Selecting the main menu “Settings\Configuration…” item.
Clicking the toolbar “Program Configuration” button.
Pressing Alt+S key combination.
In “Program configuration” dialog window the following settings are configured:
Competition name (is specified in “Competition name” input field).
List of races.
List of age groups.
Table columns.
List of referees.
Program settings.
Database settings.

List of races

List of races is on the “Races” tab of “Program configuration” dialog window.


Adding the race

To add the race:

Right click on the list of races.
Select “Add” in the context menu.
Enter the race length in the pop-up dialog window and click “Apply”.

Editing the race

To edit the race:

Select the race in the list of races by clicking the right mouse button.
Select “Edit” in the context menu.
Enter the race length in the pop-up dialog window and click “Apply”.

Deleting the race

To delete the race:

Click on the race in the list of races with your right mouse button.
Select “Delete” in the context menu.

Age groups

The list of age groups is located on the “Age groups” tab of the “Program configuration” dialog window. Each race has its own list of age groups on a specific tab. Еach list of age groups is divided into two columns based on the contestant's sex (boys/girls, men/women).


Adding the age group

To add the age group:

Right click on the list of age groups.
Select “Add” in the context menu.
In the pop-up dialog window set the parameters of the age group and click “Apply”.

Editing the age group

To edit the age group:

Right click on the list element in the column that is to be edited.
Select “Edit” in the context menu.
In pop-up dialog window set the parameters of the age group and click “Apply”.

Deleting the age group

To delete the age group:

Right click on the list element in the column that is to be deleted.
Select “Delete” in the context menu.

Table columns

To configure the view of table columns go to the “Table columns” tab of the “Program configuration” dialog window; there is the specific tab for each table on this tab, where the table view is configured.


Editing the table columns parameters

Each table column has the following parameters and control elements:

“Activate” check mark enables the column display in the table.
“Table heading” input field specifies the heading of the table column.
“Width” input field specifies width of the table column.
“Alignment” drop-down list specifies text alignment in the table column (Left — left-side alignment; Center — center alignment; Right — right-side alignment).
“Edit” check mark enables the table column element editing.
“Entry type” drop-down list specifies the database field for the data in table column.

List of referees

The list of referees is located on the “Referees” tab of the “Program configuration” dialog window.


Adding the referee

To add a new referee:

Right-click on the field with the list of referees.
Select “Add” in the context menu.
In the pop-up dialog window enter the referee’s status and full name (e.g.: Freeman G.) and click “Apply”.

Editing the referee’s details

To edit the referee’s details:

Right-click on the line with referee’s name in the list of referees.
Select “Edit” in the context menu.
In the pop-up dialog window edit the referee’s details and click “Apply”.

Deleting the referee

To delete the referee from the list of referees:

Right-click on the line with referee’s name in the list of referees.
Select “Delete” in the context menu.

Program settings

Program settings can be in the “Program configuration” dialog window on the “Service information” tab — “Information and parameters”. Settings are grouped into two types:

“Settings” type:

The “Use Sports society (Team) input field” check mark determines the use of the “Sports society” input field in the adding and editing dialog windows.
“Main window minimum size restriction” sets the main window minimum size restriction. If this option is enabled, the main window will not decrease less than the specified size.
“The hints on the age groups (in the tray)” determines, whether tooltips on the age groups are displayed on mouse move onto the contestants in the left panel (tray).
“Toolbars” determine, whether the toolbars are displayed in the main window.
Type “Displayed Information”. The settings in this group enable/disable usage and displaying the following tables: “Databases”, “Start list”, “Finish list”, “Winner list”, “Youngest and oldest contestants”, “Contestants from chosen settlement”. If the table is disabled (the table heading not checked), control elements (main menu items and toolbar buttons) will not be displayed for this table.

Database settings

Database settings are specified in the “Program configuration” dialog window on the “Service information» tab — “Database”.


Database options

Database settings are divided into four groups:

“Database type” — selecting database format. Changing of this setting overwrites the database into the new format.

“Database” — path to database and database file name:

“Name” input field determines the database file name. Available only for AbsoluteDatabase format.
“Relative path” determines the path to a database that is relative to the absolute path. Available only for AbsoluteDatabase format.
“Absolute path” input field determines the absolute path to a database. Not for editing; click “Change absolute path” button to change it.
“Change absolute path” button sets the absolute path to a database.
Thus, the path to database is set in the following format: “Absolute path”, “Relative path”, “Year of competition”, “Database file name” e.g. If “Absolute path” = C:\Program Files\RefereesHelp Race\, “Relative path” = data\, “Name” = Peoples.abs, then the full path to the database is C:\Program Files\RefereesHelp Race\data\“Year of competition”\Peoples.abs. The “Year of competition” directory is created for each year separately.
Note: changing the absolute path to a database is valid only though the current program working session; on the next startup the database absolute path settings will return to their initial values.

“Database conversion” — these buttons convert the database of the current format to the database of other format in the current database folder.

“Results precision” — determines the accuracy of the results, stored in a database: with the accuracy of seconds, tenths of a second, hundredths of a second.



Database: browsing, adding, deleting, editing, printing

To browse the database by race:

In the Race menu select the race that you want to browse and select “Browse database” in the menu.
or
Select the race that you want to browse on the toolbar and click the “Browse database” button.
The table with details of every contestant on the selected race will appear in the program’s main window.

The table has the following control elements:

“Print group”: report settings, view and printing.
“Designer” button: opens the designer to edit the report view.
“Preview” button: displays preview of the report before printing.
“Print” button: prints the report on the default printer (to configure the print settings select “File” — “Print settings” menu item).
“Referees’ signatures“ check mark: determines, whether referees’ signatures will be displayed in the report.
“Close table“ button: closes the current table.
The following actions can be applied to each contestant in this table:
Add a new contestant.
Change contestant’s details.
Delete the contestant.
To add a new contestant:
Right-click on the list of contestants and select “Add” in the context menu.
In the pop-up dialog window enter the contestant’s start number and press “Enter” on the keyboard; if a contestant with this number already exists, a pop-up window with “This start number already exists” message will appear.
Enter the contestant’s details: last name, first name (e.g.: Freeman G.), sex, year of birth, settlement and team. Then do the following:
To save the contestant’s details click “Save”.
To save the data you’ve entered and to add a new contestant click “Next”. Add a new contestant in the pop-up dialogue window.
To close the dialog window without saving the contestant’s details click “Exit”.
To edit the contestant’s details:
Right-click on the line with contestant’s details in the list of contestants and select “Edit” in the context menu.
In the pop-up dialog window enter the contestant’s details: last name, first name (e.g.: Freeman G.), sex, year of birth, settlement and team. Then do the following:
To save the contestant’s details click “Save”.
To save the data you’ve entered and to add a new contestant click “Next”. In the pop-up dialogue window enter the start number of the edited contestant and press “Enter” on the keyboard.
To close the dialog window without saving the contestant’s details click “Exit”.
Also, there is another way to edit the contestant’s details:
Double-click the field that you wish to edit, with the left mouse button.
Edit the data and press “Enter” on the keyboard.
To delete the contestant:
Right-click on the line with the contestant’s details in the list of contestants and select “Delete” in the context menu.
Click “Yes” in the pop-up dialog window to delete the contestant and “No” to cancel the deleting.

Search

To open the dialog window for searching the contestants in the database do one of the following:

Select “Search” in the “Contestants” menu.
Click “Search contestants” on the toolbar.
Press Alt+F key combination on the keyboard.
In contestants search window:
Check the criteria, by which you wish to search the contestants.
Select the year of search.
Enter the keyphrase.
Then click “Start search” next to the keyphrase input field or press “Enter” button on the keyboard.

When the search is finished you can see the preview and print the search results. The Print buttons appear in the bottom of the window, their functions are similar to the functions of “Print” elements in the database browsing tables.



Adding a new contestant

To enter the details of a new contestant do the following:

In the Race menu select the race, to which you want to add a new contestant, then in the “Enter” submenu select “New contestants” item.
or
On the toolbar select the race, to which you want to add a new contestant and click “Add new contestant”.
In the pop-up dialog window enter the contestant’s personal details: last name, first name (e.g.: Freeman G.), sex, year of birth, settlement and sports society, he represents and then:
To save the contestant’s details click “Save”.
To save the data you’ve entered and to add a new contestant click “Next”. Add the new contestant in the pop-up dialog box.
To close the dialog window without saving the contestant’s details click “Exit”.

Editing the contestant’s details

To edit the details of a contestant do the following:

In the Race menu select the race, in which the edited contestant participates, then click “Edit”.
or
On the toolbar select the race, in which the edited contestant participates and click “Edit”.
In the pop-up dialog window enter the contestant’s start number and click “Enter”. Full information about the contestant will pop up in the dialog window. Edit the contestant’s details. Then do the following:
Click “Save” to save the data.
Click “Next” to save the data you’ve entered and to edit the details of the next contestant. Edit the details of the new contestant in the pop-up window.
Click “Exit” to close the dialog window without saving the contestant’s details.

Deleting the information about all contestants

To delete the information about all contestants on a certain race do the following:

On the toolbar select the race, in which you want to delete all contestants and click “Delete database”.
Click “Yes” in the pop-up dialog window to delete all the contestants and “No” to cancel the deleting.

Entering competition results

To enter the contestant’s results do the following:

In the Race menu select the race, in which you want to enter the contestant’s result, then select “Results” in the “Enter” submenu.
or
On the toolbar select the race, in which you wish to enter the contestant’s result and click “Enter competition results”.
In the pop-up dialog window enter the contestant’s start number and click “Enter”. Then, if a contestant with this number already exists, his full name will appear to the left of the start number input field, or a message will pop up, that there is no contestant with this number in the database. Then enter the contestant’s result. Then:
Click “Save” to save the data.
Click “Next” to save the data you’ve entered and edit the details of the next contestant. Enter the next contestant’s result in the new dialog window
Click “Exit” to close the dialog window without saving the contestant’s result.


Filling the score-sheets

The following documents are automatically created on each race according to the contestants’ sex:

Start lists.
Finish lists.
Winner lists.
Start lists are created by adding the details of every contestant (see detailed description in Adding new contestant chapter). The start list is a table for every race formed by using “Races — Enter — Start list” item, or the context menu, as in the figure:

Finish lists are created only after the start lists have been created and the competition results have been entered (see detailed description in Competition results input chapter). The finish lists are tables created by using “Races — Enter — Finish list” item, or the context menu, as in the figure:

Winner lists are created for all race, according to the contestants’ sex and age group only after the finish lists have been created. The Winner List is a table created by clicking “Races — Enter — Winner list” item, or in contextual menu, as in the figure:

To control the accuracy of all previously saved data while displaying the winner list the program has a option of Checking prizewinners’ data in the existing database.


Checking prizewinners’ details

To reduce the number of possible mistakes when entering the contestants’ details the program has the option of checking the prizewinners’ details (separately on different races, contestants and age groups) according to the existing database for different years of competitions.

To check the data view the Prize list (for a certain year and contestants) and click “Check” button. After you confirm the operation (you’ll see the intermediate window with question) the program will start searching the existing database. During the search a flashing text box “Data search in progress” appears, and the indicator shows the search progress.
Caution! The search may take a long period of time depending on the database size.

If the prizewinners’ data matches over all previous years (according to the information in the database) or if the contestant’s details are not in the database, a green text box “No differences in prizewinners’ data in existing database!” appears above the table, and the table itself remains clear.

If any differences are found, the program forms a table that it fills with data on prizewinners over all years, where the differences are found. You can preview and (or) print the result; the “Print” group of elements will appear in the bottom of the window, its functions are similar to the functions of “Print” elements in the database browsing tables.